Problems with Mobile Fix and IBM Connections 3.0.1

The last two weeks i installed two IBM Connections 3.0.1.

After installing i went to IBM Fix Central and look for the latest fixes. There are 7 Fixes available and for Multi Mobile Patch it shows a superseded fix. So i decided to download patch one to seven and ignored july mobile update.

Available Connections Fixes on 2nd of march 2012

I installed the fixes as ever.

  • Updating updateinstaller
  • Disabled node synchronisation
  • Disabled Application Server automatic starting
  • shut down the Clusters
  • synchronize nodes
  • and so on.

After the installation i can’t use the mobile apps for iOS, android or Blackberry. The error messages shows “You have to install the July 2011 mobile patch to use this app.”

I made a download on Fix Central again, because i thought i made an error to ignore the july patch (LO61851), so i mark LO64399 (October Patch) to download and activated “Include requisites: Yes” and got following download options:

No other patch is shown as prerequist for this mobile patch! But i downloaded july fix (LO61851) to test this one.

I uninstalled LO64399 and startet again with LO61851. No success! After restarting i installed LO64399, but no mobile App works.

Shazza Bellamy gave me the hint to install the august mobile fix (LO63049). I searched on Fix Central, but no download was available. One of my colleagues stored the patch on our NAS and she sent it to me too. After uninstalling the other two mobile fixes i installed august fix (LO63049) and restartet again and what should i say? On both Connections Installations the mobile Apps are working.

I don’t know why LO63049 isn’t available on Fix Central and i have no idea why LO61851 is not enough for mobile Apps on my new installations. I have older systems which are updated from 2.5 or 3.0 where only LO61851 is installed and mobile apps are working.

Perhaps i can save you time with this post, because i invested some days on discovering the error and installing fixes again and again.

Update:

Today i read a post on IBM Developerworks, which describes the error and a solution. Sjaak Ursinus found the reason of the failing update: ifix LO64399 and Windows 2008 R2